Mobile Banking: System Requirements

System Requirements as of November 2021

The Mobile Banking App is available for:

APPLE

  • iPhone® (iPhone® 6S and higher, IOS 13.0 and higher)
  • iPad® (iPad® 5th generation – 2017 and higher, IOS 13.0 and higher)

GOOGLE

  • Android™ Phone (Android™ 8.0 and higher)
  • Android™ Tablet (Android™  8.0 and higher)